Настройка редактора

Вы можете создавать приложения с помощью Flutter, используя любой текстовый редактор в сочетании с нашими инструментами командной строки. Тем не менее, мы рекомендуем использовать один из наших плагинов редактора для еще большего удобства. Эти плагины обеспечивают завершение кода, подсветку синтаксиса, помощь в редактировании виджетов, поддержку запуска и отладки и многое другое.

Выполните следующие действия, чтобы добавить плагин редактора для Android Studio, IntelliJ, VS Code или Emacs. Если вы хотите использовать другой редактор, ничего страшного, переходите к следующему шагу: Тест-драйв.

Установка Android Studio

Android Studio предлагает полный, интегрированный IDE опыт для Flutter.

Кроме того, вы также можете использовать IntelliJ:

Установка Flutter и Dart плагинов

Чтобы установить их:

  1. Запустите Android Studio.
  2. Откройте настройки плагина (Configure > Plugins начиная с версии 3.6.3.0 или более поздней).
  3. Выберите плагин Flutter и нажмите Install.
  4. Нажмите Yes при запросе на установку плагина Dart.
  5. Нажмите кнопку Restart при появлении соответствующего запроса.
Примечание: До версии 3.6.3.0, доступ к плагину осуществляется следующим образом:
Откройте настройки подключаемых модулей (в MacOS перейдите в Preferences > Plugins; в Windows и Linux перейдите в File > Settings > Plugins).
Выберите Marketplace, выберите плагин Flutter и нажмите Install.

Установка VS Code

VS Code — легковесный редактор с поддержкой выполнения и отладки приложений Flutter.

  • VS Code, последняя стабильная версия

Установка Flutter и Dart плагинов

  1. Запустите VS Code.
  2. Запустите View > Command Palette….
  3. Введите “install”, и выберете Extensions: Install Extensions.
  4. В поле поиска расширений введите «flutter», в списке выберите Flutter и нажмите Install. Это также установит необходимый плагин Dart.

Проверьте вашу установку с помощью Flutter Doctor

  1. Запустите View > Command Palette….
  2. Введите “doctor”, и выберете Flutter: Run Flutter Doctor.
  3. Просмотрите вывод на панели OUTPUT при любых проблемах. Убедитесь, что в выпадающем меню в различных параметрах вывода выбран параметр Flutter.

Установка Emacs

Emacs — легкий редактор с поддержкой Flutter и Dart.

  • Emacs, последняя стабильная версия.

Установка пакета lsp-dart

Информацию об установке и использовании пакета см. в документации lsp-dart.